Leganto Notifications Email Letter

Dag-Even Martinsen Torsøe
Innlegg: 4
Registrert: ons 01 feb, 2017 10:58

Leganto Notifications Email Letter

Legg innav Dag-Even Martinsen Torsøe » tor 30 nov, 2017 8:30

Hei

Dag-Even Torsøe ved Høgskolen i Sørøst-Norge her.

Jeg jakter svaret på en liten brevgåte, foreløpig uten hell, så jeg hører om noen her vet råd.

I vår Leganto Notifications letter er det registrert feil URL, noe man skulle tro det var en smal sak å fikse, men når jeg går inn i xsl-en til brevet er den eneste url-relaterte informasjonen jeg finner et attributt:

<xsl:attribute name="href">
<xsl:value-of select="notification_data/leganto_url" />
</xsl:attribute>

Her vil jeg tro det er denne «leganto_url» som er feil, men jeg klarer ikke å finne ut hvor man retter denne.

Vet noen her hvor dette kan endres?

I Almas hjelpesider finner jeg en lite snutt som sier at man kan lime inn eksterne lenker ved å bruke en tag hvor url-en er inkludert eks: <xsl:include href="http://{$PathToWeb}/html/xsl/head.xsl"> det er mulig dette kan være en løsning, men jeg vil tro det fins enklere måter å løse dette problemet på.


Mvh
Dag-Even Torsøe
HSN-biblioteket

Emmanuelle Annie Pascal Dabin
Innlegg: 4
Registrert: fre 22 sep, 2017 9:07

Re: Leganto Notifications Email Letter

Legg innav Emmanuelle Annie Pascal Dabin » man 15 jan, 2018 10:16

Hei,
Jeg rakk ikke å oppdatere for alle institusjonene, og greit å ha det her for dokumentasjonens skyld.

Problemet blir rettet opp med February release men denne midlertidige løsningen funker.
Koden legges inn i brevet som heter /LegantoNotificationsLetter.xsl, i Alma Configuration > General > Customize letters

<span style="padding:0 0 5px 10px;">
To see all your lists <xsl:element name="a">
<xsl:attribute name="href"> https://bibsys-XX.alma.exlibrisgroup.co ... BIBSYS_XXX<xsl:text disable-output-escaping="yes">&amp;</xsl:text>auth=SAML<xsl:text disable-output-escaping="yes"> </xsl:text>
</xsl:attribute>

<xsl:attribute name="style">
<xsl:value-of select="'color:#337ab7;font-weight:bold;'"/>
</xsl:attribute>
go to Leganto
</xsl:element>

</span>

Man må passe på å skrive riktig lenke. T.o., dette er oppdatert for HSN.
Mvh Emmanuelle


Gå tilbake til «Leganto»

Hvem er online

Brukere i dette forumet: Ingen registrerte brukere og 1 gjest